President Grant PC-999

A forum for the discussion of matters of a technical nature. All such activities are undertaken at the readers discretion and own risk. If you don't know what you are doing, don't blame us if it all goes wrong!
Post Reply
User avatar
slamjam
Radio Addict
Radio Addict
Posts: 677
Joined: 02 Nov 2010, 18:52
Call Sign: 26DT871
Location: Suffolk JO02

President Grant PC-999

Post by slamjam » 17 Nov 2018, 15:29

Hi
I recently bought a grant as a spares or repairs on a chance (cheap!) Rig looks to be unmolested - It has never had the three bands enabled (came from France) I've got it to power up D75 was blown (reverse polarity maybe?)
The rig will go into TX but always around 27.525 no matter what channel you're on. Any ideas? Am I right to suspect the PLL or Adders?
IC-756PRO - IC-756PRO 3 - FT-1000D Classic - FT-990 - Acom 1000 - TS-2000 - TS-790e 2/70/23cm- TS-850SAT + XV144 -Superstar 360FM - Galaxy Saturn 2 - Icom ICR1000

User avatar
ch25
Super Member
Super Member
Posts: 469
Joined: 03 Dec 2016, 11:07
Call Sign: n0call
Location: Poland

Re: President Grant PC-999

Post by ch25 » 17 Nov 2018, 18:41

Check signals between adders and pll first.
Chris
You can't have too many antennas...

User avatar
13EL121
Super Member
Super Member
Posts: 382
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

Re: President Grant PC-999

Post by 13EL121 » 25 Nov 2018, 13:21

My Grant had bad caps. One cap in the VCO section was shorted so that the PLL got faulty. Check PLL and Binary adders at first and check frequencies of all oscillators.

User avatar
KlondikeMike
Regular
Regular
Posts: 76
Joined: 06 Jan 2014, 03:59
Call Sign: 9WR2000
Location: Edmonton, Alberta, Canada
Contact:

Re: President Grant PC-999

Post by KlondikeMike » 25 Nov 2018, 20:59

If you plan to replace the electrolytic's, I have a complete replacement kit ready to go;

https://www.ebay.com/itm/142505776247

Image
9WR2000

User avatar
slamjam
Radio Addict
Radio Addict
Posts: 677
Joined: 02 Nov 2010, 18:52
Call Sign: 26DT871
Location: Suffolk JO02

Re: President Grant PC-999

Post by slamjam » 01 Dec 2018, 14:48

Right - That bit is sorted. The voltage reg had blown the PLL and the two adders! Radio is now working on RX all channels and modes. TX there is an issue. tr50 is getting rather hot and SSB wont work - very distorted etc any ideas?

Keiron
IC-756PRO - IC-756PRO 3 - FT-1000D Classic - FT-990 - Acom 1000 - TS-2000 - TS-790e 2/70/23cm- TS-850SAT + XV144 -Superstar 360FM - Galaxy Saturn 2 - Icom ICR1000

User avatar
13EL121
Super Member
Super Member
Posts: 382
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

Re: President Grant PC-999

Post by 13EL121 » 07 Dec 2018, 16:59

I would check all Transistors and Caps in the PSU area. I had a similar fault in this area in a SS3900. There was a Transistor installed wrong way so that switching between 12V and 6V did not worked.
Grant_PSU.JPG
You do not have the required permissions to view the files attached to this post.

User avatar
13EL121
Super Member
Super Member
Posts: 382
Joined: 16 Sep 2008, 20:55
Call Sign: 13DA121
Location: Germany
Contact:

Re: President Grant PC-999

Post by 13EL121 » 07 Dec 2018, 17:02

Also check Bias at the Driver and Finals. Does voltage switching work from 6v to 12v from AM/FM to SSB?

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests