Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

A forum for the discussion of matters of a technical nature. All such activities are undertaken at the readers discretion and own risk. If you don't know what you are doing, don't blame us if it all goes wrong!
pienari
Regular
Regular
Posts: 35
Joined: 18 Feb 2017, 13:05
Call Sign: 56la422
Location: Finland
Contact:

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by pienari » 04 Jan 2018, 11:11

I think i can try to measure my Colt Excalibur if i get any reasonable measure results.

My Excalibur works fine but some stations have told bad modulation on usb.
Donno sure but other told its fine?.
Paljon pilalle tinailtuja koneita. ;)
Mobile. Harrier CB X, Megawatt 4000,Zetagi B300p.
Home. Colt Excalibur SSB , 2el Quad, Eurocb EA-150.

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM125A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 15:27

@pienari: Greetings to a Fin in Finland from a Fin in Sweden. :D

Thanks for offering help but since the Colt Excalibur has different design in the clarifier circuit the values you will get are different.
Is it the Colt Excalibur SSB you have or the Excalibur SSB?
The reason why I am asking is that it looks like Colt Excalibur SSB just has a fine tune clarifier in RX only while the Excalibur SSB seems to have a pullswitch built into the clarifier knob that is a actually a selector between two pots so that the user can choose fine tuning in RX or coarse tuning in RX and TX.

See the difference in these two pictures:
Colt Excalibur SSB with only RX clarifier: http://www.forumradioamatori.it/forum/i ... 6065;image

[EDIT! 2018-01-05] My mistake! I see now on the picture that this model does indeed have both a RX only AND a RX/TX clarifier. It is the knob on the left side called just "Tune" and the coarse tune is on the right side and is labeled "Clarifier on this model". This model seems to have the motherboard PTBM131A4X (http://www.zen96216.zen.co.uk/cb/schema ... 131a4x.htm. The clarifier circuit on this one is identical with the one I have (PTBM125A4X) except for the AVR regulator Q36 and the switching transistors Q33, Q34 and Q35 so I guess the voltages in this area should be pretty identical.


Excalibur SSB with a RX or RX and TX clarifier: https://i.ebayimg.com/images/g/ZOwAAOSw ... -l1600.jpg
Note how the Excalibur SSB has pull out / push in symbol below the clarifier knob to choose between RX only or RX/TX clarifier.
I found one example of the schematics for the Excalibur SSB at http://www.cbtricks.com/radios/excalibu ... 15_sch.pdf and the clarifier circuit seems to be quite similar but instead of two pots (one for RX and one for RX and TX) the Excalibur SSB (NOT the Colt Excalibur SSB) seems to have a switch to chose if clarifier works for RX only or both RX and TX (via the switch in the dual-pot VR801/VR503) AND a third pot on the motherboard (?) VR15 to further adjust the center of the clarifiers.

Anyway, I´ll keep on poking around in the area of the clarifier and varactor diode D6. I´ll try to measure the components before cathode and anode of D6 to see if there are some values that are out of line. Especially around R21 due to:

R21 (coarse tune both RX and TX)
Left side shows 3.834V in RX and drops 13mV to 3.821V in TX
Right side is difficult since it actually affects the frequence of the oscillator here but anyway: RX shows 3.797V and drops 12mV to 3.785V in TX


@lbcomms: Come to our rescue please! :D :wave:
Last edited by CrazyFin on 05 Jan 2018, 08:36, edited 2 times in total.

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 16:45

I found this well done schematics for the CRT SS 3900 by Rick Jackson Euro Radio Co at http://www.cbtricks.com/radios/crt/ss_3 ... mosfet.pdf

The clarifier circuit there looks quite similar to the one in PTBM131A4X with the big exception that there is a trimpot VR21 that is used for adjusting the coarse clarifier so that the TX freq does not go out off line. I will use this info to check:

R21 that goes to cathode of D6 for correct value of 100K (Isn't this quite high?)
R17 and R18 next to Q36 emitter and maybe change R18 to a trimpot so that I can adjust bias in TX mode to give correct TX freq
PTBM125A4X - clarifier circuit.jpg
You do not have the required permissions to view the files attached to this post.

User avatar
DX-Digger
Radio Addict
Radio Addict
Posts: 741
Joined: 27 Jul 2009, 22:01
Call Sign: TM205
Location: ... - --- -.- . --- -. - .-. . -. -

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by DX-Digger » 04 Jan 2018, 17:19

I have just thought of something which may well be worth checking
I assume for all the tests done you are using the built in PSU?
Have you tried with a better regulated external PSU?

My thinking is could the built in psu be slightly dropping voltage when TXing?
They never were a fantastic design.

Like I say Im clutching at straws now as have exhausted other avenues, If the voltage is dropping slightly it should show up on the collector of the switching transistor on TX

It is a strange fault with no obvious solution atleast to me anyway and needs input from an expert which I am not.

Have to admit its got me baffled
ʎɐqǝ uo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 17:51

Yepp I checked the built-in PSU. Always do that first with these kind of base stations.
No fault on the power supply levels from the internal PSU but during all tests at my labb bench I always use my 13.8VDC, 40A linear power supply that gives nice and pure DC with good stable high current if needed. 8)

When I am back at home later tonight I will check the paths I mentioned above and report back here and hooooopefully @lbcomms might check in to give us expert advice. :D :thumbup:

User avatar
DX-Digger
Radio Addict
Radio Addict
Posts: 741
Joined: 27 Jul 2009, 22:01
Call Sign: TM205
Location: ... - --- -.- . --- -. - .-. . -. -

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by DX-Digger » 04 Jan 2018, 18:12

Yeah I should of guessed you would use external decent psu, I hope you manage to sort it as its bugging me now lol :D
FFF
ʎɐqǝ uo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 20:16

Ha! I am confused as well. :D

I just don't know why I have a shelf with about 5-6 of these cybernet based radios that all have really strange and difficult faults. I have been able to fix some but these 5 are still staring at me and this Petrusse Excalibur 2002 works just fine with super modulation in all modes and not too much/big IMD:s/spurioses as well so it is quite frustrating that I am not able to nail this problem. {bnghd}

Anyway, just for the sake I checked voltages in the AVR section (Q36) and actually compared them with the voltage charts for transistors on PTBM125A4X that you find for example in the Cybernet Export Service Manual (example in your post viewtopic.php?f=53&t=54813&p=497413#p497436

There it states that Q36, the main requlator should have
Collector 13.65V (I have 13.70 so this is ok) It drops to 13.45 in TX (AM mode ch 20)
Base 10.05V (I have 10.16 so I guess that is ok too?) No change in TX
Emitter should be 10.83V according to this BUT I have only 8.98V and it drops 30mV to 8.95V in TX (AM mode ch 20) :shock:

When I go to the R17/R18 that is after emitter Q36 and where I have 8.98V and measure there I see 3.84V in RX and 3.83V in TX which is inline with my earlier measurements at cathode D6. Cathode D6 drops 10mV in TX (and at the same time anode D6 goes from 913mV in RX to about 2.46mV in TX)

So a new question now is why do I have only 8.98V on the AVR Q36 emitter when it should be about 10.8V? (Or is the transistor voltage chart wrong?)

User avatar
DX-Digger
Radio Addict
Radio Addict
Posts: 741
Joined: 27 Jul 2009, 22:01
Call Sign: TM205
Location: ... - --- -.- . --- -. - .-. . -. -

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by DX-Digger » 04 Jan 2018, 21:22

the 10V on the base is set by that zener diode. so that seems to be working fine maybe slightly high and the input (collector) has what i assume is supply voltage 13.8 from psu
ok you replaced C180 and you have 10.16 which is slightly high but within tolerence i think, that 10V sets the gain of the regulator so seems ok.

What about c182 ? C182 is connected to the collector and to ground (leaky?) if it checks out ok do you have another regulator Transistor you can try?
ʎɐqǝ uo pɹɐoqʎǝʞ ɐ ʎnq ı ǝɯıʇ ʇsɐן ǝɥʇ sı sıɥʇ

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 21:33

Yepp both C180 and C179 has been replaced with brand new ones and with 105 degree rating as well.
I lifted out R18 and measured it. It shows 7.95k which is within tolerance from the 8.2k in the schematics.
While R18 was out I measured Q36 emitter again and it still shows 8.98V so the low voltage on Q36 E is not caused by the path of R18 to cathode D6.

I´ll check C182 as well but if that one is leaky then I would expect that the collector voltage should also be low? Currently it is at 13.71V which is perfect (and drops to 13.45 in TX AM mode).

I also checked C114 (in the RF AMP section) but that one checked out ok too and while it was out of circuit I still had the low voltage on Q36 emitter.

I guess now the next step would be to figure out what to measure next in the Q33, Q34 and Q35 area but I just cant understand why something in this area would be bad since both RX and TX works fine except for that annoying up-jump of approx +1.7 to +1.8kHz in TX. I am constantly having my freq connected to TP1 (via a 1000pF ceramic cap to avoid to much loading) and I can see that while in RX the freq for that band is perfectly at 20.105MHz (within spec +/- 50Hz) and when I go TX it jumps to 20.905MHz, i.e 800Hz up... :roll:

I do have brand new 2SD837:s so I could actually test with replacing the 2SD837. I've read somewhere that one could actually replace it with a higher speced transistor to keep the regulating power more steady but I can't find at the moment which one to replace it with?
Last edited by CrazyFin on 04 Jan 2018, 22:06, edited 1 time in total.

pienari
Regular
Regular
Posts: 35
Joined: 18 Feb 2017, 13:05
Call Sign: 56la422
Location: Finland
Contact:

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by pienari » 04 Jan 2018, 21:43

Yes this one have a pullswitch built into the clarifier knob , rx or tx/rx.
Colt Excalibur ssb PTBM131A4X. 5 band am/fm/ssb.

Just tested TP1 rx 20.104930MHz tx 20.105035MHz

Q36 someone have chanced to 2SD325.
Last edited by pienari on 04 Jan 2018, 22:08, edited 1 time in total.
Paljon pilalle tinailtuja koneita. ;)
Mobile. Harrier CB X, Megawatt 4000,Zetagi B300p.
Home. Colt Excalibur SSB , 2el Quad, Eurocb EA-150.

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 22:05

@pienari: Thanks, that confirms that your RX and TX frequencies at TP1 are just tiny 105Hz off from each other. Mine jumps 800Hz there...

pienari
Regular
Regular
Posts: 35
Joined: 18 Feb 2017, 13:05
Call Sign: 56la422
Location: Finland
Contact:

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by pienari » 04 Jan 2018, 22:09

Yes i think you have some voltage what is too hi on tx.

How i can help to measure something?.
Paljon pilalle tinailtuja koneita. ;)
Mobile. Harrier CB X, Megawatt 4000,Zetagi B300p.
Home. Colt Excalibur SSB , 2el Quad, Eurocb EA-150.

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 22:31

It would be great if you could measure the voltages in RX and TX on cathode junction of D801/D802 and D95/D96.
Do the measurements with clarifier in RX mode only and in RX/TX mode too, i.e. totally 8 measurements. Thanks!

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 22:36

I think 2SD837 can replaced with TIP130? It should be a good replacement due to its higher current (8A) and wattage (70W) rating?

2SD325 seems a little bit weaker than 2SD837 when looking at the specs?

CrazyFin
Super Member
Super Member
Posts: 100
Joined: 08 Jan 2014, 12:12
Location: Stockholm, SWEDEN

Re: Petrusse Excalibur 2002 (PTBM131A4X) - TX freq off approx 1.7kHz in all modes and all bands, RX seems ok

Post by CrazyFin » 04 Jan 2018, 22:39

@pienari:
Sorry I was looking at the Excalibur SSB schematic which seems to be different than yours (PTBM131A4X)!!

Can you measure your Q36 emitter voltage please? I have about 8.98V in RX AM there and transistor voltage charts says it should be around 10.86V.

Can you also measure the voltage at the left side of R21 and R11 (both in TX and RX in AM mode ch 20)?

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests