Cobra 148 MK2 10Khz off All Bands

A forum for the discussion of matters of a technical nature. All such activities are undertaken at the readers discretion and own risk. If you don't know what you are doing, don't blame us if it all goes wrong!
User avatar
Otter
Veteran
Veteran
Posts: 2715
Joined: 04 Apr 2008, 21:42
Call Sign: 26TM439

Re: Cobra 148 MK2 10Khz off All Bands

Post by Otter » 25 May 2018, 07:29

Connect pin 9 of IC 6 to the IC6's VCC as opposed to 0V. If it doesn't go up another 10kc replace IC 6. The pin input may be blown while the rest of the chip is OK.
"To this day the words Stirling bridge conjour pride in every Scotsman's heart, while to an Englishman those same words conjour literally no feelings at all." - Cunk on Britain S1 E1
Gorgon Brown - a man with all the joie de vivre of a haunted cave in Poland. S1 E3

User avatar
cb4ever104
Veteran
Veteran
Posts: 4498
Joined: 28 Jul 2011, 21:26
Location: Alicante , España

Re: Cobra 148 MK2 10Khz off All Bands

Post by cb4ever104 » 25 May 2018, 07:48

Otter wrote:
25 May 2018, 07:29
Connect pin 9 of IC 6 to the IC6's VCC as opposed to 0V. If it doesn't go up another 10kc replace IC 6. The pin input may be blown while the rest of the chip is OK.
That's what I was originally thinking , but I re-read the post .
currentstatus wrote:
23 May 2018, 18:43
Also re-aligned the PLL TP-3 16.49000 mid
So it can't be that if he's getting the right N code input on the PLL and frequency on TP3 . That's why I was asking about the 10.965 mixer stage . Maybe someone's been tweeking .
30TM060
Paul aka "Sammy". (108) PY60 Old Paisley DX Group (RIP Rab Markie)
Ex GM0 , now EA5 .
Handle "Fortune Hunter" back in "the day"
Radios ....? Anything that says "TAIWAN R.O.C" on the back.

currentstatus
Regular
Regular
Posts: 45
Joined: 18 May 2018, 06:50
Location: Valencia, Spain

Re: Cobra 148 MK2 10Khz off All Bands

Post by currentstatus » 25 May 2018, 09:25

cb4ever104 wrote:
25 May 2018, 07:25
Also . What frequency are you getting from the 10.695 stage at TP6 ?

Sammy
Yep I tested pin 4 OSC Out on PLL 10.240 seems OK. All original FL3 & X1.
I'm getting 10.6925 on USB @ TP6 ?? So that's not right..

IMG_5788.JPG
You do not have the required permissions to view the files attached to this post.
Last edited by currentstatus on 25 May 2018, 10:10, edited 3 times in total.

currentstatus
Regular
Regular
Posts: 45
Joined: 18 May 2018, 06:50
Location: Valencia, Spain

Re: Cobra 148 MK2 10Khz off All Bands

Post by currentstatus » 25 May 2018, 09:36

Otter wrote:
25 May 2018, 07:29
Connect pin 9 of IC 6 to the IC6's VCC as opposed to 0V. If it doesn't go up another 10kc replace IC 6. The pin input may be blown while the rest of the chip is OK.
Which pin is VCC..

User avatar
Otter
Veteran
Veteran
Posts: 2715
Joined: 04 Apr 2008, 21:42
Call Sign: 26TM439

Re: Cobra 148 MK2 10Khz off All Bands

Post by Otter » 25 May 2018, 10:13

Pin 16 of IC6.

Technically it's VDD since it's CMOS. VCC would be for TTL.
"To this day the words Stirling bridge conjour pride in every Scotsman's heart, while to an Englishman those same words conjour literally no feelings at all." - Cunk on Britain S1 E1
Gorgon Brown - a man with all the joie de vivre of a haunted cave in Poland. S1 E3

User avatar
Otter
Veteran
Veteran
Posts: 2715
Joined: 04 Apr 2008, 21:42
Call Sign: 26TM439

Re: Cobra 148 MK2 10Khz off All Bands

Post by Otter » 25 May 2018, 10:27

Also on CH 19 mid check that the frequency on pin 2 of the MC145106 is 1.490MHz. If it's 1.50MHz I would replace IC6.
"To this day the words Stirling bridge conjour pride in every Scotsman's heart, while to an Englishman those same words conjour literally no feelings at all." - Cunk on Britain S1 E1
Gorgon Brown - a man with all the joie de vivre of a haunted cave in Poland. S1 E3

User avatar
cb4ever104
Veteran
Veteran
Posts: 4498
Joined: 28 Jul 2011, 21:26
Location: Alicante , España

Re: Cobra 148 MK2 10Khz off All Bands

Post by cb4ever104 » 25 May 2018, 10:43

currentstatus wrote:
25 May 2018, 09:25
I'm getting 10.6925 on USB @ TP6 ?? So that's not right..
Correct . That's not right . What are you getting on AM and LSB ?
30TM060
Paul aka "Sammy". (108) PY60 Old Paisley DX Group (RIP Rab Markie)
Ex GM0 , now EA5 .
Handle "Fortune Hunter" back in "the day"
Radios ....? Anything that says "TAIWAN R.O.C" on the back.

currentstatus
Regular
Regular
Posts: 45
Joined: 18 May 2018, 06:50
Location: Valencia, Spain

Re: Cobra 148 MK2 10Khz off All Bands

Post by currentstatus » 25 May 2018, 11:19

Otter wrote:
25 May 2018, 10:27
Also on CH 19 mid check that the frequency on pin 2 of the MC145106 is 1.490MHz. If it's 1.50MHz I would replace IC6.
Hmmm..connect pins 9 - 16 of IC6 the display & TX/RX LED cuts out.. don't think she likes that.
The freq @ pin 2 of PLL Mid ch 19 is.. 2.214Mhz ? What..
IMG_5794.JPG
You do not have the required permissions to view the files attached to this post.

currentstatus
Regular
Regular
Posts: 45
Joined: 18 May 2018, 06:50
Location: Valencia, Spain

Re: Cobra 148 MK2 10Khz off All Bands

Post by currentstatus » 25 May 2018, 11:21

cb4ever104 wrote:
25 May 2018, 10:43
currentstatus wrote:
25 May 2018, 09:25
I'm getting 10.6925 on USB @ TP6 ?? So that's not right..
Correct . That's not right . What are you getting on AM and LSB ?
AM I can't get a stable reading.. LSB is 10.6975.. as opposed to the USB 10.6925

User avatar
Otter
Veteran
Veteran
Posts: 2715
Joined: 04 Apr 2008, 21:42
Call Sign: 26TM439

Re: Cobra 148 MK2 10Khz off All Bands

Post by Otter » 25 May 2018, 12:09

currentstatus wrote:
25 May 2018, 11:19
Otter wrote:
25 May 2018, 10:27
Also on CH 19 mid check that the frequency on pin 2 of the MC145106 is 1.490MHz. If it's 1.50MHz I would replace IC6.
Hmmm..connect pins 9 - 16 of IC6 the display & TX/RX LED cuts out.. don't think she likes that.
The freq @ pin 2 of PLL Mid ch 19 is.. 2.214Mhz ? What..
IMG_5794.JPG
You would need to remove the link connecting pin 9 to 0V before connecting it to VDD.

You want a frequency counter to read the frequency at pin 10 of the PLL. The scope isn't designed for measuring precise frequencies.

Alternatively, measure the voltages on pins 9 to 17 of the PLL on channel 19 mid and post them here. Don't need an exact voltage. Just write anything over 4.5V as '1' and anything below 1V as a '0'. 149 should be '0 1001 0101', 150 is '0 1001 0110'
Last edited by Otter on 25 May 2018, 12:14, edited 1 time in total.
"To this day the words Stirling bridge conjour pride in every Scotsman's heart, while to an Englishman those same words conjour literally no feelings at all." - Cunk on Britain S1 E1
Gorgon Brown - a man with all the joie de vivre of a haunted cave in Poland. S1 E3

User avatar
cb4ever104
Veteran
Veteran
Posts: 4498
Joined: 28 Jul 2011, 21:26
Location: Alicante , España

Re: Cobra 148 MK2 10Khz off All Bands

Post by cb4ever104 » 25 May 2018, 12:09

currentstatus wrote:
25 May 2018, 11:21
cb4ever104 wrote:
25 May 2018, 10:43
currentstatus wrote:
25 May 2018, 09:25
I'm getting 10.6925 on USB @ TP6 ?? So that's not right..
Correct . That's not right . What are you getting on AM and LSB ?
AM I can't get a stable reading.. LSB is 10.6975.. as opposed to the USB 10.6925
Well , you'll need to sort that out . I've had that issue before on a few radios . For me it's normally been one of those little 470uH inductors (L24/25/26) that's went faulty . So for you on AM it might be L24 if it's the same issue . Check the voltage to the stage first though and make sure it's stable .

Cheers
30TM060
Paul aka "Sammy". (108) PY60 Old Paisley DX Group (RIP Rab Markie)
Ex GM0 , now EA5 .
Handle "Fortune Hunter" back in "the day"
Radios ....? Anything that says "TAIWAN R.O.C" on the back.

User avatar
Otter
Veteran
Veteran
Posts: 2715
Joined: 04 Apr 2008, 21:42
Call Sign: 26TM439

Re: Cobra 148 MK2 10Khz off All Bands

Post by Otter » 25 May 2018, 12:16

I don't think you can actually measure the 10.695 on AM on a Cobra 148 GTL-DX Sammy
"To this day the words Stirling bridge conjour pride in every Scotsman's heart, while to an Englishman those same words conjour literally no feelings at all." - Cunk on Britain S1 E1
Gorgon Brown - a man with all the joie de vivre of a haunted cave in Poland. S1 E3

User avatar
cb4ever104
Veteran
Veteran
Posts: 4498
Joined: 28 Jul 2011, 21:26
Location: Alicante , España

Re: Cobra 148 MK2 10Khz off All Bands

Post by cb4ever104 » 25 May 2018, 12:44

Otter wrote:
25 May 2018, 12:16
I don't think you can actually measure the 10.695 on AM on a Cobra 148 GTL-DX Sammy
Hi Tim . Yeap . Sorry . You got me there :) You can't . On AM I usually measure the 27Mhz mixed carrier signal at the output and align it there . You can only do the USB and LSB sections .

Sammy
30TM060
Paul aka "Sammy". (108) PY60 Old Paisley DX Group (RIP Rab Markie)
Ex GM0 , now EA5 .
Handle "Fortune Hunter" back in "the day"
Radios ....? Anything that says "TAIWAN R.O.C" on the back.

currentstatus
Regular
Regular
Posts: 45
Joined: 18 May 2018, 06:50
Location: Valencia, Spain

Re: Cobra 148 MK2 10Khz off All Bands

Post by currentstatus » 25 May 2018, 12:57

Otter wrote:
25 May 2018, 12:09
currentstatus wrote:
25 May 2018, 11:19
Otter wrote:
25 May 2018, 10:27
Also on CH 19 mid check that the frequency on pin 2 of the MC145106 is 1.490MHz. If it's 1.50MHz I would replace IC6.
Hmmm..connect pins 9 - 16 of IC6 the display & TX/RX LED cuts out.. don't think she likes that.
The freq @ pin 2 of PLL Mid ch 19 is.. 2.214Mhz ? What..
IMG_5794.JPG
You would need to remove the link connecting pin 9 to 0V before connecting it to VDD.

You want a frequency counter to read the frequency at pin 10 of the PLL. The scope isn't designed for measuring precise frequencies.

Alternatively, measure the voltages on pins 9 to 17 of the PLL on channel 19 mid and post them here. Don't need an exact voltage. Just write anything over 4.5V as '1' and anything below 1V as a '0'. 149 should be '0 1001 0101', 150 is '0 1001 0110'

IC6 (JP54 N/C) - with 8.4v from pin 16 to pin 9.. nothing.. no freq change TX/RX.
But we've risen the rig now by another 10Kc by removing JP54 yes.

With JP54 reconnected.. ch19 Mid (bare in mind this is ch20)

pin 9 - 0v - 0
pin 10 - 8.4v - 0
pin 11 - 0v - 0
pin 12 - 0v - 1
pin 13 - 8.4 - 1
pin 14 - 0 - 0
pin 15 - 8.4 - 1
pin 16 - 0 - 0
pin 17 - 8.4 - 1

currentstatus
Regular
Regular
Posts: 45
Joined: 18 May 2018, 06:50
Location: Valencia, Spain

Re: Cobra 148 MK2 10Khz off All Bands

Post by currentstatus » 25 May 2018, 13:00

cb4ever104 wrote:
25 May 2018, 12:09
currentstatus wrote:
25 May 2018, 11:21
cb4ever104 wrote:
25 May 2018, 10:43


Correct . That's not right . What are you getting on AM and LSB ?
AM I can't get a stable reading.. LSB is 10.6975.. as opposed to the USB 10.6925
Well , you'll need to sort that out . I've had that issue before on a few radios . For me it's normally been one of those little 470uH inductors (L24/25/26) that's went faulty . So for you on AM it might be L24 if it's the same issue . Check the voltage to the stage first though and make sure it's stable .

Cheers
Thanks Sammy!! I'll get some ordered now.. looks like I'm going to need a stock up in general :)

Post Reply

Who is online

Users browsing this forum: timbob58 and 1 guest