Lincoln mic problems

A forum for the discussion of matters of a technical nature. All such activities are undertaken at the readers discretion and own risk. If you don't know what you are doing, don't blame us if it all goes wrong!
Post Reply
User avatar
NightProwler
Veteran
Veteran
Posts: 2683
Joined: 08 Feb 2012, 22:31
Call Sign: 163TM186
Location: South Wales

Lincoln mic problems

Post by NightProwler » 31 Mar 2018, 20:02

Evening all, I got a real noodle scratcher here. I got two MK1 President Lincoln mics here and both have no out going audio. I have tested the mic elements and they are fine, The PTT switches are fine, Tested the mic cables and they are fine but still no audio out of them. I have a working Lincoln mic so I checked the wiring against them and everything checks out. Starting to fry my brain now. Anyone got any suggestions? Although I think I have checked everything and to be fair theres not a lot that can go wrong in a mic.

Cheers dudes...Rich :thumbup:
Shorter of breath and one day closer to death

User avatar
14CS06
Radio Addict
Radio Addict
Posts: 936
Joined: 04 Mar 2012, 09:15
Location: JN33LN - ALPES-MARITIMES-06 France

Re: Lincoln mic problems

Post by 14CS06 » 31 Mar 2018, 20:15

Hello

As you age the glue breaks the microphone wires

Image

Image

@+
Claude
Last edited by 14CS06 on 13 Apr 2018, 16:09, edited 1 time in total.
Photo Collector CB RADIO

User avatar
NightProwler
Veteran
Veteran
Posts: 2683
Joined: 08 Feb 2012, 22:31
Call Sign: 163TM186
Location: South Wales

Re: Lincoln mic problems

Post by NightProwler » 31 Mar 2018, 20:26

Thing is Claude I have done a continuity test on everything and all checks out. As the tree said to the lumberjack, Im stumped :wtf:
Shorter of breath and one day closer to death

MiXiN
Super Member
Super Member
Posts: 136
Joined: 17 Dec 2012, 03:02

Re: Lincoln mic problems

Post by MiXiN » 01 Apr 2018, 00:05

14CS06 wrote:
31 Mar 2018, 20:15
Hello

As you age the glue breaks the microphone wires

Image

Image

@+
Claude
Glue again? It seems to be a big problem in the Lincoln, 2830, HR2510, etc'.

I'm having trouble zooming in on the image of that Mic' you posted, so please can you point out where the glue is on it.

Is it the same yellow glue as used inside the rig on the Toroids, Regulator's, et al?

User avatar
14CS06
Radio Addict
Radio Addict
Posts: 936
Joined: 04 Mar 2012, 09:15
Location: JN33LN - ALPES-MARITIMES-06 France

Re: Lincoln mic problems

Post by 14CS06 » 01 Apr 2018, 06:57

Hello

Please look at this pic

Image

Image

@+
Claude
Last edited by 14CS06 on 13 Apr 2018, 16:09, edited 1 time in total.
Photo Collector CB RADIO

sonoma
Regular
Regular
Posts: 76
Joined: 29 Oct 2017, 04:12

Re: Lincoln mic problems

Post by sonoma » 01 Apr 2018, 07:15

have you cleaned the switch with a good cleaner. I have seen these little switches go bad and have weak contacts at times. it will show good with a ohm meter but when you put power to it not making a real good contact to let a signal pass through it. just a thought.

User avatar
Mudslinger
Legend
Legend
Posts: 6752
Joined: 28 Jul 2010, 07:11
Location: Oxfordshire

Re: Lincoln mic problems

Post by Mudslinger » 01 Apr 2018, 07:32

The element might still be faulty even if it meters out correctly.

I have had problems on a few radios like this. I think the moisture from peoples breath (or even just dribble :o ) makes the inside part of the element corrode which prevents it moving. Hence no audio.

Uniden and Maxon element seem favorite for this.
Last edited by Mudslinger on 01 Apr 2018, 07:33, edited 1 time in total.
Mudslinger - Simon
26TM274
26CT612

There is no such thing as a Fidelity 1000 which is too good to scrap.

User avatar
Mudslinger
Legend
Legend
Posts: 6752
Joined: 28 Jul 2010, 07:11
Location: Oxfordshire

Re: Lincoln mic problems

Post by Mudslinger » 01 Apr 2018, 07:32

Double post
Mudslinger - Simon
26TM274
26CT612

There is no such thing as a Fidelity 1000 which is too good to scrap.

User avatar
NightProwler
Veteran
Veteran
Posts: 2683
Joined: 08 Feb 2012, 22:31
Call Sign: 163TM186
Location: South Wales

Re: Lincoln mic problems

Post by NightProwler » 01 Apr 2018, 08:27

Simon you are spot on, I checked again last night and yes thats the problem. Weird how I got two of these mics both with faulty mic elements. Oh well anyone want to buy a Lincoln mic with a dead mic element? two minute repair job if you have the right element to go in. I already got a working one so I dont need three of them :D
Shorter of breath and one day closer to death

User avatar
14CS06
Radio Addict
Radio Addict
Posts: 936
Joined: 04 Mar 2012, 09:15
Location: JN33LN - ALPES-MARITIMES-06 France

Re: Lincoln mic problems

Post by 14CS06 » 13 Apr 2018, 16:10

MiXiN wrote:
01 Apr 2018, 00:05
14CS06 wrote:
31 Mar 2018, 20:15
Hello

As you age the glue breaks the microphone wires

Image

Image

@+
Claude
Glue again? It seems to be a big problem in the Lincoln, 2830, HR2510, etc'.

I'm having trouble zooming in on the image of that Mic' you posted, so please can you point out where the glue is on it.

Is it the same yellow glue as used inside the rig on the Toroids, Regulator's, et al?
Photo Collector CB RADIO

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests