Ex-Brick Lincoln almost there....!

A forum for the discussion of matters of a technical nature. All such activities are undertaken at the readers discretion and own risk. If you don't know what you are doing, don't blame us if it all goes wrong!
User avatar
Snake Plissken
Regular
Regular
Posts: 45
Joined: 01 Aug 2017, 13:47
Location: Escaped NY to Berkshire UK

Re: Ex-Brick Lincoln almost there....!

Postby Snake Plissken » 07 Aug 2017, 11:52

Super - glued the pick in position, and all is good now guys - thanks for the advice!

This is a highly recommended mod!

A) I no longer need an external antenna
B) I have somewhere to put my cocktail sausages
C) If I increase AM carrier power, I can warm said sausages

Just needs a red TX bulb on the tip now.....although this might cause sausage unload issues :lol: :lol: :lol:
Unidens (one or two)..
Cybernets (a few more)..
Stalker ST-9F DX Colonel FR360 Stag 357 Midland 79-900 Zodiac Tokyo Pegasus III Transceiver MkV
Cheiza CB702 workshop monitor :lol:
A few more, I forget...

Snake Plissken - Rescuing Presidents since a 1981 version of 1997 :D

User avatar
Snake Plissken
Regular
Regular
Posts: 45
Joined: 01 Aug 2017, 13:47
Location: Escaped NY to Berkshire UK

Re: Ex-Brick Lincoln almost there....!

Postby Snake Plissken » 07 Aug 2017, 15:46

Well, after a lot more squinting and swearing, it looks like it was down to a dry joint on one leg of R50 on mainboard, leading to the detector PCB..

Re-flowed it; now FM works without me prodding at the board :D

Thought I'd post the fix in case anyone else in future has a similar issue :thumbup:
Unidens (one or two)..
Cybernets (a few more)..
Stalker ST-9F DX Colonel FR360 Stag 357 Midland 79-900 Zodiac Tokyo Pegasus III Transceiver MkV
Cheiza CB702 workshop monitor :lol:
A few more, I forget...

Snake Plissken - Rescuing Presidents since a 1981 version of 1997 :D


Return to “CB & 11m Multi-Mode Modification & Repair”

Who is online

Users browsing this forum: No registered users and 1 guest