Yaesu frg100 vfo seized, Damaged vfo disc? :/

The place to talk about specific amateur radio equipment and all types of accessories, fixes, repairs and modification.
Post Reply
N1ova
Regular
Regular
Posts: 52
Joined: 08 Dec 2004, 16:38
Location: Flint North Wales

Yaesu frg100 vfo seized, Damaged vfo disc? :/

Post by N1ova » 17 Feb 2019, 10:18

Help please My tuning knob on my frg100 seized solid last night, i stripped it down cleaned, greased and sorted it. However on stripdown the silver disc in the vfo unit bent. Now i can't move through the frequencies. Would damage to the silver disc cause this?
You do not have the required permissions to view the files attached to this post.

mw0uzo
Regular
Regular
Posts: 20
Joined: 26 Oct 2018, 19:19
Call Sign: mw0uzo

Re: Yaesu frg100 vfo seized, Damaged vfo disc? :/

Post by mw0uzo » 02 Mar 2019, 11:52

I've seen this before with IC735 optical encoders.

Yes damage to the disc or misaligned optical parts will cause this. You can flatten out the disk in an attempt to restore it:

1. Place the disk inside a folded piece of kitchen roll, soaked in IPA.
2. Put this between two flat, smooth pieces of metal. Heavier the better.
3. Place the stack on a very sturdy surface, then strike it hard with a heavy hammer several times
4. Inspect disk, repeat if necessary.

Avoid directly bending or manipulating the disk with tools, unless you are very careful you will cause more damage.

User avatar
Tigersaw
Radio Addict
Radio Addict
Posts: 753
Joined: 19 Oct 2013, 15:48
Call Sign: GW6RRL
Location: Llanwrtyd Wells Powys
Contact:

Re: Yaesu frg100 vfo seized, Damaged vfo disc? :/

Post by Tigersaw » 02 Mar 2019, 12:05

Image

mw0uzo
Regular
Regular
Posts: 20
Joined: 26 Oct 2018, 19:19
Call Sign: mw0uzo

Re: Yaesu frg100 vfo seized, Damaged vfo disc? :/

Post by mw0uzo » 02 Mar 2019, 22:33

Tigersaw wrote:
02 Mar 2019, 12:05
Image
that's the stuff :clap:

N1ova
Regular
Regular
Posts: 52
Joined: 08 Dec 2004, 16:38
Location: Flint North Wales

Re: Yaesu frg100 vfo seized, Damaged vfo disc? :/

Post by N1ova » 04 Mar 2019, 22:51

All sorted had to get another vfo encoder. Thanks for your help.

Post Reply