BF 888s Radio Set Up Problems PLEASE HELP!!

A place for new members to say hello and to introduce yourself.

If you're not sure where to post, try here!
Post Reply
User avatar
Registered New User
Registered New User
Posts: 1
Joined: 04 Nov 2017, 11:19

BF 888s Radio Set Up Problems PLEASE HELP!!

Post by gareth_f01 » 04 Nov 2017, 13:44

Hi There and thanks for taking the time to read my post.

OK the problem that I am having with the radios is after i downloaded the software from the radio, i then changed the frequency and then wrote this to the device. When I turned on the radio the vioce was in chinese and after the voice the radio just beeps nothing but beeping.

When I read back what I have wrote to the radio it gives all channels are blank and the settings are all changed? this is like its not wrote correctly or reverting to factory settings? I have looked to make sure that the COM port is correct and that the cable is being seen correctly. I have also down graded the Serial port driver to software, but this dose not correct the problem. I am currently using a windows 8.2 on my laptop and have not seen any error messages with the software.

i have tried to program the device using BF 888s PC software there has been no error messages only when i forget to turn on the radio before I read and Write :lol: .

Details of setup

Windows 8.1 64 bit
BAOFENG 28-020-122 Programming Cable
BF-888S_v1.05 programming software
BF-888s Radio

Here is the cable that i have purchased ... TF8&psc=1

The radios when connected do not do anything, when i turn them on the software or the radio are lifeless. When reading and writing to the radios the LED on the radio turns and flashes green at a fast pace.

I turn off the radio and unplug it from the system, when turning the radio back on I get a Chinese announcement when it was set to English and then just beeping coming from the radio.

Please take a look at the attachments and any help is highly appreciated. I am hoping that i am doing something wrong maybe some one has done the same as me before.

Please see videos was not able to attach them

Best Regards

Kind Regards

Gareth :thumbup:

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests